General [M]ayhem

Go Back   General [M]ayhem > Real Time Sub-Forums > Armageddon and Survival
Register Members List Mark Forums Read [M]erchandise Calendar

Reply
 
Thread Tools
Kirby
 
Bad ammo or Gun problem? Pics!

I was at the range today and had a couple of failure to fires which is a first with the Winchester white box ammo and my gun. Is my firing pin just not making a big enough mark on the round or is it because these bullets are cheap target loads and aren't that reliable?

Failure to fire round is on the right.




See dat one on the right


Should that round have fired? With the other rounds that misfired I was able to load them back up and shoot them which makes me think it could be something wrong with my firing pin/hammer springs.

For those wondering, the gun was a Sig P226 with about 1500 rounds through her.
Old 09-17-2009, 04:40 PM Kirby is offline  
Reply With Quote
#1  

Advertisement [Remove Advertisement]

Tazman0072
 
I never had a issue with winchester white box with my low mileage P228. That dimple does look a bit weaker then the left bullet. Are you sure it only has 1500 rounds through her?
Old 09-17-2009, 04:53 PM Tazman0072 is offline  
Reply With Quote
#2  

Kirby
 
Yup. I bought it new. How do you knock out the pin that holds the firing pin and assembly in place? I've been trying for the last 20 min with a hammer and a punch tool. I think I'm just making it worse.
Old 09-17-2009, 05:32 PM Kirby is offline  
Reply With Quote
#3  

Tazman0072
 
Go to sigforum.com and ask. They have a armorer section for stuff like this!
Old 09-17-2009, 05:33 PM Tazman0072 is offline  
Reply With Quote
#4  

dagamore
 
looks like a light primer strike, even though its new take ti to a gun smith and have them make sure the firing pin is moving freely and that the spring on the hammer is the right one.
Old 09-17-2009, 10:02 PM dagamore is offline  
Reply With Quote
#5  

punisher
 
punisher's Avatar
 
I had this problem on pistols that had low tension mainsprings/hammer springs installed, and then only with Remington primers. It has been awhile since I owned a Sig (220) but it seems like with the slide off you should be able to depress any pin locks/safeties and use a pick to press the firing pin to check for binding/stoppage.
__________________
"Oil leak, what oil leak? That puddle under the car is just sweat from all that horsepower."
Old 09-18-2009, 01:29 AM punisher is offline  
Reply With Quote
#6  

DHermit
www.TShirtReview.com
 
DHermit's Avatar
 
I've prob shot well over 15,000 rounds of WWB and never had a Failure to Fire. Probably your spring tension, get it looked at by a gunsmith.
Old 09-18-2009, 09:45 AM DHermit is offline  
Reply With Quote
#7  

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -7. The time now is 03:24 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.