General [M]ayhem

Go Back   General [M]ayhem > General [M]ayhem > Automotive [M]ayhem
Register Members List Mark Forums Read [M]erchandise Calendar

Reply
 
Thread Tools
someone else
 
Quote:
Originally Posted by SamFarber View Post
Good engine. Served me well for over a decade and then someone else.

Yeah, i love my cherokee. I've put over 130k miles on it in 4 years. Doesn't generally leave me stranded, this is the first "out of the ordinary" repair I've had to do. We've had four 4L in the family, two cherokees and two wranglers. still have two cherokees and 1 wrangler. great engines. great vehicles too, really. can't complain about any of them, except the massive valve cover gasket leak in the other cherokee, haha.
__________________
Driving:
2005 Acura RSX Type-S
1996 Pontiac Trans Am - LT1 + T56, not stock
2001 Jeep Cherokee Sport

Shooting:
Nikon D300, Rolleiflex 2.8F, Nikon F100, Olympus OM-1, Pentax 645
Old 03-05-2014, 10:42 PM someone else is offline  
Reply With Quote
#16  

Advertisement [Remove Advertisement]

lollersk8s
HOLY FUCK I AM RETARDED
 
lollersk8s's Avatar
 
Quote:
Originally Posted by DopefishLives View Post
Wow, first time I've seen that happen on a 4.0L. Fairly-common on the Audi 2.2/2.3L inline 5's due to the use of plastic drive teeth. So did the pump itself fail/seize, causing the teeth to shear, or was it just the cam sensor itself?

Plastic teeth, wow. That's just sad
__________________
Originally Posted by she nice
i do drink but it's not as effective for immediate relief
Old 03-05-2014, 11:26 PM lollersk8s is offline  
Reply With Quote
#17  

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -7. The time now is 07:45 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.